cancel
Showing results for 
Search instead for 
Did you mean: 

Egnyte Connect support for macOS 10.13 High Sierra

Aaron Marks
Resident

Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

I installed macOS 10.13 public beta today to find that Egnyte Connect doesn't appear to be compatible. I get an error about FUSE being too old of a version. Please support this well before public release. We have many clients that will be buying new Macs that are pre-loaded with 10.13 on Day 1. 

Labels (2)
1 Solution

Accepted Solutions
Retired Employee Sagar
Retired Employee

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Gentlemen,

I got news for you. We released an update to Desktop Sync and Egnyte Drive for Mac to fully support macOS High Sierra. 

We recommend customers to upgrade their Egnyte applications before upgrading to macOS High Sierra to avoid seeing any issues.

You can find more information in the announcement link below: - 

https://helpdesk.egnyte.com/hc/en-us/articles/115001693011

Thanks

Sagar.

PS. Help others find answers by selecting "Accept as Solution" if a post answers your question."
0 Kudos
12 Replies
Retired Employee Sagar
Retired Employee

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Hi Aaron,

You are right. We don't support MAC OS 10.13 High Sierra beta. We plan to test it in full close to, when Apple releases their Gold Master edition of High Sierra( It's not yet available).

So, we don't plan to support any of the beta versions. However, we will add support for the GA version when it comes out. Product Team is already working on this as I update this post. 

Thanks

Sagar

PS. Help others find answers by selecting "Accept as Solution" if a post answers your question."
0 Kudos
Aaron Marks
Resident

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Sagar,

The reason Apple (Developer Preview) and Microsoft (Fast Ring) both release previews of their software is so that industry developers can update their software ahead of GA. 

I think it's out of touch with the current expectation of Egnyte customers to assume that it's ok to wait to test. 

It's nearly guaranteed that any dependency incompatibilities with macOS 10.13 that exist currently will also be an issue upon Apple's GA release. 

Please consider raising this with your dev team.

Thank you. -Aaron

 

 

Retired Employee Sagar
Retired Employee

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Aaron,

I have passed on your feedback to the Product Development team now. I will write back if I have anything to update on this post. 

Thanks

Sagar.

PS. Help others find answers by selecting "Accept as Solution" if a post answers your question."
0 Kudos
Retired Employee Sagar
Retired Employee

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Aaron,

I had passed on your feedback to our Product Team.  They do understand the point you made in this post and I and writing back to you since I have something to share.

I am told that we do limited testing with the beta versions of High Sierra with beta versions of the internal driver we use to serve up our virtual file system. This way we can be in a position to support High Sierra well ahead of its release date. The other complication with High Sierra is the plenty of changes Apple has introduced to the file system that necessitates a lot of testing.

The problem with releasing a version of our product which supports the beta version of High Sierra is that the beta version of the driver may impact other versions of Mac.

So we do test well in advance of the release of High Sierra but we reserve the full round of testing for when Apple announces their Gold Master version of High Sierra (which comes before the production release). This way we will have a GA ready client by the time High Sierra is released.

Regards

Sagar.

PS. Help others find answers by selecting "Accept as Solution" if a post answers your question."
0 Kudos
jorn knuttila
Resident

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

I agree with Aaron. Sadly, Egnyte has historically taken what is essentially a "we're not going to bother, stop asking" stance when it comes to allowing Egnyte Drive working with any MacOS systems tagged as beta.

While I think "Here's a beta to try with the beta; YMMV" would be a good idea, Egnyte does not concur.

0 Kudos

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Hi Jorn,

I'm from the products team at Egnyte. I understand your frustration and will definitely take your feedback about providing early beta versions with support for new OS releases on board.

The specific challenge with High Sierra is the new file system for which we know there are known issues. In addition to this, High Sierra has new behavior around kernel extensions that significantly impacts our application (https://developer.apple.com/library/content/technotes/tn2459/_index.html#top) so we're attempting to create the best user experience in light of this.

Either way your point about having beta releases or production releases with limited support for new versions of the OS is something we'll take on board.

Thanks!

- Kash

 

0 Kudos

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Hi Kash,

I completely understand the issues with not releasing a client for High Sierra. However, the beta has been around for quite some time, and there's no excuse for not having a beta at this point.

Will you be supporting High Sierra when it launches a little over a week? If not, what is the ETA?

Thanks,

Jeffrey

Retired Employee Sagar
Retired Employee

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

Hi Jeffrey,

We do limited testing with the beta versions of High Sierra with beta versions of the internal driver we use to serve up our virtual file system so we can be in a position to support High Sierra well ahead of its release date.  

The problem with releasing a version of our product which supports the beta version of High Sierra is that the beta version of the driver may impact other versions of Mac.

So we do test well in advance of the release of High Sierra but we reserve the full round of testing for when Apple announces their Gold Master version of High Sierra (which comes before the production release). This way we will have a GA ready client by the time High Sierra is released.

I have written to Kash to see if he has can give us an ETA. I will write back once I hear from him. 

Thanks

Sagar.

PS. Help others find answers by selecting "Accept as Solution" if a post answers your question."
0 Kudos
jorn knuttila
Resident

Re: Egnyte Connect support for macOS 10.13 High Sierra

Jump to solution

macOS 10.13 has gone GM

0 Kudos